undefinedfix
Sign in

Can developers know that Axios is not supported and handled by current browsers?

spriteun edited in Fri, 25 Nov 2022

RT, for example, QQ browser just opened, the default may not be ie11, Axios should not be used, and then hope to remind users to switch to ie11 compatible mode

3 Replies
Techtoy
commented on Fri, 25 Nov 2022

Axios uses ES6 syntax, add a Polyfill to make it compatible

scscscscs
commented on Fri, 25 Nov 2022

Axios on the browser side is implemented based on XMLHttpRequest. Now there are browsers that don't support Ajax (except that JS scripts are disabled in browsers)?

fonch
commented on Sat, 26 Nov 2022

Axios and fetch I never use. AJAX is enough, not compatibility